Elevated API response times
Incident Report for Emailable
Resolved
This incident has been resolved.
Posted Mar 26, 2022 - 01:48 EDT
Investigating
We are currently investigating this issue.
Posted Mar 26, 2022 - 01:07 EDT
This incident affected: API (Emailable API, TheChecker API (Legacy)).