SSL Error
Incident Report for Emailable
Postmortem

At 7:00 PM EST our team was alerted to an SSL error on our origin servers. Our team immediately began investigating the issue and found the cause was due to an old certificate that was mistakenly left on our load balancer. The certificate was removed and the SSL error was resolved.

Posted Dec 06, 2023 - 19:37 EST

Resolved
We are currently investigating this issue.
Posted Dec 06, 2023 - 19:00 EST