Elevated Errors and Latency
Incident Report for Emailable
Postmortem

At 7:22 AM EST our monitoring systems identified an increase in latency and errors across many of our systems. We quickly identified and resolved the issue. By 7:37 AM EST all errors were mitigated and our systems were operating normally.

Posted Sep 06, 2023 - 09:42 EDT

Resolved
We are currently investigating this issue.
Posted Sep 06, 2023 - 07:30 EDT