Elevated Error Rates on /v1/verify
Incident Report for Emailable
Postmortem

Summary

At approximately 12:42 AM we detected an elevated number of API requests to our Single Verifier /v1/verify endpoint returning an Internal Error (500 status code). Upon investigation, we determined the root cause was due to a connection limit issue introduced by new code with one of our databases. At 1:29 AM we confirmed the connection issue was resolved and the error was no longer being returned.

Cause

Following a new code release we identified a bug that limited connections to one of our databases, mainly reducing the volume of requests we could process at our /v1/verify endpoint.

Impact

Initial requests made to our /v1/verify endpoint started returning the following response.

{ "message": ”Internal Error” }

Due to the way this impacted our system, retrying these requests would return a proper response.

Posted May 26, 2021 - 03:07 EDT

Resolved
This incident has been resolved.
Posted May 26, 2021 - 01:29 EDT
Investigating
We're experiencing an elevated rate of API errors and are currently investigating this issue.
Posted May 26, 2021 - 00:42 EDT
This incident affected: API (Emailable API).